IMOS X - Service degraded

Incident Report for Veson

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 16:54 EDT

Monitoring

We have mitigated the performance issue and are continuing to monitor.
Posted Mar 19, 2026 - 10:45 EDT

Identified

We are experiencing degraded performance affecting IMOS X UI and workflows, including delayed processing and intermittent errors. Our team is actively investigating and working to resolve the issue.
Posted Mar 19, 2026 - 08:02 EDT
This incident affected: IMOS X (Web Application, APIs, Claims CoCaptain).